Trouble in Daytona...955 - Triumph Forum: Triumph Rat Motorcycle Forums

The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-13-2012, 02:57 PM Thread Starter
New Member
Production 125
Main Motorcycle: Daytona 955i
 
386Rider's Avatar
 
Join Date: Sep 2012
Location: Daytona Beach
Posts: 10
Trouble in Daytona...955

Hello everyone,
I'm new here and I would greatly appreciate some input on what could be wrong with my bike. I have a 2000 Daytona 955i and first of all it is idling high (2000) when it normally idles at 1200 and either when I'm taking off or down-shifting, there is a misfire kind of sound. All of this started happening after a day where I ran the bike pretty hard. Any clue to what I may have done to my baby?
386Rider is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-13-2012, 03:23 PM
New Member
Newbie
Main Motorcycle: trident
 
Join Date: Nov 2012
Location: cumbria
Posts: 3
hi the bike mite have an air leak between the air box and the injectors, a blocked balance tube, defective injector, maybe a defective pickup coil misfire wise, air leak at the exhaust header pipe ,just a few areas to maybe look hopefully not an engine prob .reg craig
T309 is offline  
post #3 of 4 (permalink) Old 11-13-2012, 04:03 PM
Senior Member
Team Owner
Main Motorcycle: Hinckley Triumph
 
Join Date: Dec 2006
Posts: 4,978
Have a look at your IACV (Idle Air Control Valve) hoses, they may possibly be cracked and perished, letting in air.



DeanRider is offline  
post #4 of 4 (permalink) Old 02-19-2013, 01:31 PM Thread Starter
New Member
Production 125
Main Motorcycle: Daytona 955i
 
386Rider's Avatar
 
Join Date: Sep 2012
Location: Daytona Beach
Posts: 10
Trouble in Daytona...955

Any suggestions for a new chain and sprocket kit?


Sent from Motorcycle.com Free App
386Rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble getting into and out of 1st eigenvector Tiger 1050 - Mods & Workshop 4 10-21-2012 08:13 PM
Daytona 955i Trouble. HELP! eDUNCAN Biker Hang-Out 5 06-11-2011 08:28 PM
Trouble with 04 daytona dredgery Triumph SuperSports 9 05-17-2011 01:20 PM
Daytona 600 trouble code 04daytona600 Triumph SuperSports 11 03-22-2011 09:55 PM
Oh boy am i in trouble 24gt Speed Triple Forum 34 03-09-2007 09:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome