Hi from NZ - Triumph Forum: Triumph Rat Motorcycle Forums
The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-04-2012, 03:55 AM Thread Starter
New Member
Main Motorcycle: Triumph Bonneville 2005
Join Date: Nov 2012
Location: New Zealand
Posts: 3
Other Motorcycle: ninja 250,CBR 600
Extra Motorcycle: suzuki fxr 150 racer
Hi from NZ

Just bought myself a 2005 790 Bonnie in green.
Lovely bike,has done 47k kms.
Love it...One question though speedo seems really erratic (swings between 80 and 120 kmh when riding at 100) is this normal? Any possible solutions.Thanks and greetings to all.
bigreddog is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-04-2012, 04:05 AM
Senior Member
Team Owner
Main Motorcycle: Hinckley Triumph
Join Date: Dec 2006
Posts: 4,978

Post up your question in the appropriate technical / model forum and I am sure you will get some help with your problem.

DeanRider is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome