Engine management light 2010 Thruxton - Triumph Forum: Triumph Rat Motorcycle Forums
The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-22-2011, 06:25 AM Thread Starter
New Member
Production 125
Main Motorcycle: Triumph Thruxton
Join Date: Aug 2011
Location: Marthas Vineyard
Posts: 9
Engine management light 2010 Thruxton

Has any one experienced the Engine management malfunction indicator light go on at a low fuel moment but the bike still runs fine?
I have gone through the 3 cool hot runs and it won't reset, dealer or not?
twisted7 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 08-22-2011, 02:25 PM
Site Supporter
Main Motorcycle: Tiger 955i
Haggis's Avatar
Join Date: Sep 2003
Location: Alberta, Canada
Posts: 12,308
Other Motorcycle: Sprint RS
Extra Motorcycle: Honda XL250
Welcome to the site.

Take a look around at the different forums and become familiar with them, especially http://www.triumphrat.net/club-cafe/

I've copied your question to the Twins Technical forum: Someone will be able to answer your question there.

Also check out http://www.triumphrat.net/biker-hang-out/ where we have fun chatting about anything (except politics and religion ).

Don’t be shy about posting! The only dumb questions are the ones we don’t ask.

BTW You can modify your profile/favourite bike description, to include the year & model - this makes for instant identifier for others when you have questions

Each forum has a moderator to answer your questions about the running of the site and to solve any problems. If you need something lets us know.
Haggis is offline  
post #3 of 3 (permalink) Old 11-08-2012, 10:18 AM
New Member
Main Motorcycle: Triumph Sprint ST
Join Date: Nov 2012
Location: Basingstoke/England
Posts: 1
Just happened to mine, 2003 Sprint ST, this is the 2nd time it happened, last time 3x hot cycles seemed to work, doing this now but is there a more permanent resolution to this?
mckenzke67 is offline  
Sponsored Links

Quick Reply
All posts must adhere to Forum Rules

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 UK Scrambler Engine Management Light & Speedo Vman900 Twins Technical Talk 5 04-15-2011 12:15 PM
engine management light on and broken park light SideBuRn Sprint Forum 4 08-20-2010 08:19 AM
Engine Management Light waglet The Welcome Center 1 08-02-2010 01:18 PM
Engine Management Light lovecuba Sprint Forum 1 10-20-2008 09:36 PM
Engine Management light black Tiger Workshop (archive) 2 06-24-2006 05:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome