2004 Sprint won't start - Triumph Forum: Triumph Rat Motorcycle Forums

Sprint Forum Sprint ST - Sprint RS - Sprint GT Join in on one of the world's most active Triumph Sport-Touring Forums.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-20-2012, 11:31 AM Thread Starter
New Member
Newbie
Main Motorcycle: 2004 Triumph RS 955
 
Join Date: Dec 2012
Location: Wichita, Ks
Posts: 3
2004 Sprint won't start

Hello,
New member here. My 2004 Triumph RS 955 won't start, I noticed one of the wires on my fuel gauge sending unit was broken. Is it possible this is causing the ECU to not turn the fuel pump on, preventing the bike not to start? Thanks for your help
KansasTom is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-20-2012, 01:51 PM
Lifetime Premium
Site Supporter
Formula Extreme
Main Motorcycle: 2005 Daytona 955i
 
PaulM's Avatar
 
Join Date: Aug 2004
Location: Northampton England UK
Posts: 617
Garage
No a broken wire only gives a fault signal it does not stop the pump from running. You have another problem with the starting.
Paul
PaulM is offline  
post #3 of 5 (permalink) Old 12-21-2012, 03:30 AM
Lifetime Premium
Site Supporter
World SuperBike
Main Motorcycle: My '04 Sprint-ona
 
RexxyPup's Avatar
 
Join Date: Jun 2005
Location: Swindon, UK
Posts: 1,977
Other Motorcycle: Want a 675
Extra Motorcycle: I wish!
Garage
Fuse or relay is most likely, or if your fuel sender wire is broken (the one on the bottom of the square part of the tank) what about the condition of the wires on the pump feed on the side?

WARNING:! Low flying Sprint-ona ahead!

Old Albums
New Albums
RexxyPup is offline  
post #4 of 5 (permalink) Old 12-21-2012, 11:48 PM
Immoderate Moderator
Site Supporter
Nova
Main Motorcycle: Black '04 Sprint RS
 
KitNYC's Avatar
 
Join Date: Jul 2007
Location: Austin, TX
Posts: 15,420
Other Motorcycle: Blue '04 Sprint RS
Extra Motorcycle: Tedium 850
Garage
What does it do? Do the lights come on when you turn the key? Does the motor turn over? The more detail you can give us, the more likely we are to be able to help.

Cheers,
-Kit
KitNYC is offline  
post #5 of 5 (permalink) Old 12-23-2012, 10:58 AM Thread Starter
New Member
Newbie
Main Motorcycle: 2004 Triumph RS 955
 
Join Date: Dec 2012
Location: Wichita, Ks
Posts: 3
Got it going again, it was a faulty safety switch. Thanks everyone and this forum.
KansasTom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Triumph RS 955 won't start KansasTom The Welcome Center 0 12-19-2012 12:20 PM
Daytona 2004 Won't Start Placea Daytona Deliberations 14 04-04-2011 10:26 AM
2004 955i Wouldn't Start The_Jackal Daytona Deliberations 10 05-20-2009 03:53 PM
2004 sprint ThruxtonMI Sprint Forum 9 04-05-2007 02:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome