Sprrint 1050 starting problem - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
Sprint Forum Sprint ST - Sprint RS - Sprint GT Join in on one of the world's most active Triumph Sport-Touring Forums.

LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 12-08-2012, 11:52 AM
Senior Member
World SuperBike
Main Motorcycle: Sprint RS,Black,04
frider's Avatar
Join Date: Mar 2005
Location: Long Island,NY
Posts: 2,040
Other Motorcycle: That one
Extra Motorcycle: Yorkie and Silky WOOF!!
955i series had a well known left hand switchgear/wiring harness bad crimp....bout 4inches.....10cm from the switchgear.....

horn would stop/and or nothing on starter, as clutch interlock seemed to get confused by it.........

not sure if the 1050 suffered from it.............my RS did!!

Chocolate Food of the Gods!!!!!!
frider is offline  
Sponsored Links
post #12 of 12 (permalink) Old 12-08-2012, 12:26 PM
Senior Member
Supersport 600
Main Motorcycle: '06 ST ABS
UlsterSpud's Avatar
Join Date: Jul 2005
Location: Comox BC Canada
Posts: 185
Other Motorcycle: '14 Trophy SE, '09 Bonne
Extra Motorcycle: '88 Suzuki Katana 1100
Did the intermittent starting problem appear before you changed the clutch lever? My bike was doing the same thing, sometimes I had to pull and release the lever a bunch of times and then it would start. I lubed the switch pin and the problem went away untill I installed the Pazzo levers. That's when I found that moving the adjust to the shorter span would not let the switch pin fully extend, though because I ride with the lever set at #4 I have not experienced any problem since.

I still suspect the clutch switch so it may be worth removing the lever to expose the pin and then work it while pushing the starter switch.

Good luck.
UlsterSpud is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
My recent experiences working on my 1050 Sprint, and questions about starting problem CBLove Sprint Forum 20 10-19-2012 08:34 AM
Tiger 1050 starting problem britlad Tiger Chat 4 09-04-2012 08:23 AM
1050 starting problem zep1975 Sprint Forum 15 12-08-2011 12:56 PM
2007 triumph sprint st 1050 starting problem ppggmd Sprint Forum 36 11-21-2011 02:27 PM
Srint ST 1050 Starting Problem RonnieD155 Sprint Forum 21 02-21-2011 03:36 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome