Idle problem? - Triumph Forum: Triumph Rat Motorcycle Forums
Sprint Forum Sprint ST - Sprint RS - Sprint GT Join in on one of the world's most active Triumph Sport-Touring Forums.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-30-2012, 10:06 PM Thread Starter
Lifetime Premium
Site Supporter
Minitwins
Main Motorcycle: 2000 Sprint ST
 
capt775's Avatar
 
Join Date: Sep 2012
Location: Shreveport, Louisiana USA
Posts: 15
Other Motorcycle: 1967 Honda Cub 90
Extra Motorcycle: Honda XR230
Idle problem?

Elvira is running good. Cept. When I stop at a light or wherever, she's idleing at about 21 grand. I can slip the clutch out and she'll drop to where she's supposed to be and hold it.

I let her just sit there and burn gas a time or two and after about 30 or 45 seconds she dropped herself to where she was supposed to be. I don't know. Anybody got a suggestion?

Thanks guys.

I was born with nothing, and still have most of it.
capt775 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-30-2012, 10:44 PM
Immoderate Moderator
Site Supporter
Legend
Main Motorcycle: '04 Sprint RS
 
KitNYC's Avatar
 
Join Date: Jul 2007
Location: Austin, TX
Posts: 14,883
Other Motorcycle: 2000 Sprint ST
Extra Motorcycle: 2011 Thruxton
Garage
That's usually the idle air control valve, or the corrugated plastic tubes that run between it and the head. First thing to do would be to check those tubes for leaks.

Cheers,
-Kit
KitNYC is offline  
post #3 of 3 (permalink) Old 12-01-2012, 02:54 PM Thread Starter
Lifetime Premium
Site Supporter
Minitwins
Main Motorcycle: 2000 Sprint ST
 
capt775's Avatar
 
Join Date: Sep 2012
Location: Shreveport, Louisiana USA
Posts: 15
Other Motorcycle: 1967 Honda Cub 90
Extra Motorcycle: Honda XR230
Thanks Kit, I'll check it out. Probably time to change my filter anyway.

I was born with nothing, and still have most of it.
capt775 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hot Idle Problem 79 T-140 Barnstorm Classic, Vintage & Veteran 2 05-07-2012 10:15 AM
R3 Idle Problem dave willard The Rocket Science Forum 40 06-17-2011 12:55 PM
hot idle problem banzai7863 T3 Sport / Touring Forum 4 05-02-2009 06:08 PM
Idle rpm problem sajgon Sprint Forum 6 11-15-2008 06:55 AM
Idle problem gbc The Rocket Science Forum 2 09-18-2006 06:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome