Bought 09 S3, heads been off, can anyone tell me how theirs runs? - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Speed Triple Forum Rants and ravings about the best naked triple on the planet!

Reply
 
LinkBack Thread Tools Display Modes
Old 11-16-2012, 04:59 AM   #11 (permalink)
Member
Supersport 400
Main Motorcycle: Daytona 600
 
D6Rider313's Avatar
 
Join Date: Aug 2010
Location: Azle, TX
Posts: 84
Other Motorcycle: SV1000s
Did some research on this "tune of death" and found lots of ranting and raving, what's the scoop?

Sent from my HTC One X using Motorcycle.com Free App
D6Rider313 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-16-2012, 05:01 AM   #12 (permalink)
Member
Supersport 400
Main Motorcycle: Daytona 600
 
D6Rider313's Avatar
 
Join Date: Aug 2010
Location: Azle, TX
Posts: 84
Other Motorcycle: SV1000s
Quote:
Originally Posted by Brodino View Post
Like Joe Houle said, that must be one nice tune. I have an 09 but it does not do any of that. I do get a small blue flame when I let off but only at higher revs
So your bike doesn't clutch up at 70mph and get vertical with 1/4 throttle? This is my main question I'm needing answered cuz if not then something else is most definitely done to it and that's what I'm wanting to find out

Sent from my HTC One X using Motorcycle.com Free App
D6Rider313 is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 05:17 AM   #13 (permalink)
Senior Member
Formula Extreme
Main Motorcycle: '08 Sprint ST
 
sussurf's Avatar
 
Join Date: Nov 2009
Location: Sydney, Australia
Posts: 784
Other Motorcycle: '06 Daytona 955i
Extra Motorcycle: Husqvarna Terra 650
1. get a cable and connect it to TuneEcu. Compare the map to TOD, stock maps or whatever you want. It will tell you alot about the fueling & ignition which would give you some idea of how it's been tuned. From there you can assume away.

2. there shouldn't be any goo around the head. Sure you're not looking at the cam cover?

3. check inside your throttle tube to see if it's had the quick throttle mod done.

4. could've had a 'Tona transplant but TuneEcu will tell you that.
__________________
cheers,

Phil
sussurf is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 07:00 AM   #14 (permalink)
Senior Member
Supersport 600
Main Motorcycle: 2011 Speed Triple
 
Ben_'s Avatar
 
Join Date: Oct 2012
Location: Sydney, Australia
Posts: 153
I've had my new 11' speed for a couple of months now and I still haven't held full throttle in first gear... Anything over 1/4 will lift the front.

Triples are rad.
Ben_ is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 10:27 AM   #15 (permalink)
Member
Grand Prix 125
Main Motorcycle: Speed Triple R
 
Join Date: Mar 2012
Location: Sydney
Posts: 32
The S3 is very different from the other bikes you mentioned but what you describe does sound like a non-standard tune has been loaded into it because the blue flame thing is unusual and it sounds even more flighty than normal. I doubt that the head has been off based on your description as they generally have that appearance.

Last edited by Tokoloshgolem; 11-16-2012 at 10:31 AM.
Tokoloshgolem is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 10:45 AM   #16 (permalink)
Lifetime Premium
Site Supporter
Grand Prix 125
Main Motorcycle: Speed Triple 1050
 
blue350zed's Avatar
 
Join Date: Sep 2010
Location: NW Florida
Posts: 34
Other Motorcycle: Yamaha R6
Extra Motorcycle: Kawasaki KX250F
I want F&F blue flames
blue350zed is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 02:44 PM   #17 (permalink)
Senior Member
Grand Prix 500
Main Motorcycle: 2009 Speed Triple
 
Join Date: Apr 2012
Location: Atlanta, GA
Posts: 110
Quote:
Originally Posted by D6Rider313 View Post
So your bike doesn't clutch up at 70mph and get vertical with 1/4 throttle? This is my main question I'm needing answered cuz if not then something else is most definitely done to it and that's what I'm wanting to find out

Sent from my HTC One X using Motorcycle.com Free App
Mine does not get vertical at 1/4 throttle even with spirited starts. I have not tried clutching up at 70mph so i cannot answer that. But i can tell you that I am extremely envious of your machine!
Brodino is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 02:51 PM   #18 (permalink)
New Member
Grand Prix 125
Main Motorcycle: 2009 speed triple
 
Join Date: Jul 2011
Location: Irvine
Posts: 27
Nice maybe your bike took steroids? From what I was told the tune of death is for low mounts.. And I hear Zards are not good to the s3 tuned or not.
bbmakmak is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 03:21 PM   #19 (permalink)
Member
Supersport 400
Main Motorcycle: Daytona 600
 
D6Rider313's Avatar
 
Join Date: Aug 2010
Location: Azle, TX
Posts: 84
Other Motorcycle: SV1000s
Quote:
Originally Posted by sussurf View Post
1. get a cable and connect it to TuneEcu. Compare the map to TOD, stock maps or whatever you want. It will tell you alot about the fueling & ignition which would give you some idea of how it's been tuned. From there you can assume away.

2. there shouldn't be any goo around the head. Sure you're not looking at the cam cover?

3. check inside your throttle tube to see if it's had the quick throttle mod done.

4. could've had a 'Tona transplant but TuneEcu will tell you that.
What do I need to connect to tune ecu? Also I am positive I'm not talkin about the cam cover, I am quite knowledgeable when it cones to engines as I have rebuilt several

Sent from my HTC One X using Motorcycle.com Free App
D6Rider313 is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 03:22 PM   #20 (permalink)
Member
Supersport 400
Main Motorcycle: Daytona 600
 
D6Rider313's Avatar
 
Join Date: Aug 2010
Location: Azle, TX
Posts: 84
Other Motorcycle: SV1000s
Quote:
Originally Posted by sussurf View Post
1. get a cable and connect it to TuneEcu. Compare the map to TOD, stock maps or whatever you want. It will tell you alot about the fueling & ignition which would give you some idea of how it's been tuned. From there you can assume away.

2. there shouldn't be any goo around the head. Sure you're not looking at the cam cover?

3. check inside your throttle tube to see if it's had the quick throttle mod done.

4. could've had a 'Tona transplant but TuneEcu will tell you that.
Also what is a tona transplant

Sent from my HTC One X using Motorcycle.com Free App
D6Rider313 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
cyl heads born to be mild T3 Sport / Touring Forum 23 07-24-2011 01:06 PM
01 different heads bonnevillebilly Twins Technical Talk 30 11-26-2007 07:23 PM
bought a leo vince high mount, new tune, and runs horrible rodubs22 Daytona Deliberations 8 09-08-2007 01:34 AM
Heads Up! drainbamage Speed Triple Forum 1 03-16-2006 09:30 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 04:19 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.