How should my S3 run at low speed? - Page 3 - Triumph Forum: Triumph Rat Motorcycle Forums
Speed Triple Forum Rants and ravings about the best naked triple on the planet!

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 26 (permalink) Old 12-04-2012, 08:23 PM
Member
Grand Prix 125
Main Motorcycle: 2011 S3
 
Join Date: Jul 2011
Location: Quakertown, PA
Posts: 31
Quote:
Originally Posted by bevivino1 View Post
I have a stock 2011, it is smooth as silk in the riding conditions you describe.
Like others have said, sounds like a minor fueling issue.
My 2011 (all stock) is the same as above, smooooooth.
bevivino1 is offline  
Sponsored Links
Advertisement
 
post #22 of 26 (permalink) Old 12-05-2012, 01:44 PM
Member
Grand Prix 250
Main Motorcycle: 2011 Speed Triple 1050
 
Dr.Speed's Avatar
 
Join Date: Nov 2012
Location: Philadelphia, PA
Posts: 71
Quote:
Originally Posted by bevivino1 View Post
My 2011 (all stock) is the same as above, smooooooth.
I have a 2011, which is stock performance-wise. It's very smooth as well. Almost too smooth
Dr.Speed is offline  
post #23 of 26 (permalink) Old 12-05-2012, 03:55 PM
Senior Member
Supersport 400
Main Motorcycle: 2012 Bonneville Black
 
Join Date: Oct 2012
Location: Philadelphia
Posts: 100
Extra Motorcycle: 2015 Ducati Diavel
I have a 2012 Speed that I purchased used with about 2500 miles on it. The first thing I noticed with the slight hesitation/engine vibration from anything below 3k rpms. I thought there was something wrong with the engine, but the tech said the factory map runs lean for emissions purposes.

Once I put the Arrow high mounts on and loaded up the tune with Tunecu, it completely eliminated all hesitation down low and the bike now rides super smooth!
Stripleville is offline  
post #24 of 26 (permalink) Old 12-05-2012, 10:22 PM
Senior Member
Formula Extreme
Main Motorcycle: '08 S3
 
Joe Houle's Avatar
 
Join Date: Nov 2007
Location: Lower Alabama
Posts: 825
Other Motorcycle: '02 S4
Extra Motorcycle: '08 Scrambler
Did you reset adaptives in the course of loading the new tune?

SUPPORT THE TROOPS!!
Joe Houle is offline  
post #25 of 26 (permalink) Old 12-06-2012, 02:23 AM
Senior Member
Supersport 400
Main Motorcycle: 2012 Bonneville Black
 
Join Date: Oct 2012
Location: Philadelphia
Posts: 100
Extra Motorcycle: 2015 Ducati Diavel
Quote:
Originally Posted by Joe Houle View Post
Did you reset adaptives in the course of loading the new tune?
Yes, I did the 10-20 minute idle without touching the throttle until the TPS light turned green
Stripleville is offline  
post #26 of 26 (permalink) Old 12-06-2012, 07:21 AM
Senior Member
Formula Extreme
Main Motorcycle: '08 S3
 
Joe Houle's Avatar
 
Join Date: Nov 2007
Location: Lower Alabama
Posts: 825
Other Motorcycle: '02 S4
Extra Motorcycle: '08 Scrambler
This alon has a big effect on how the bike runs. I would start there.

SUPPORT THE TROOPS!!
Joe Houle is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Speed Triple or 2003 speed four???? TheBigCat Speed Triple Forum 8 04-26-2010 04:31 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome