First problem with my Speed Four! - Triumph Forum: Triumph Rat Motorcycle Forums
Speed Triple Forum Rants and ravings about the best naked triple on the planet!

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-15-2004, 08:53 PM
Posts: n/a
And since we share the same headlights, I thought someone else might have had this happen too...

So I was riding the other day (Saturday, to be exact), pretty much all day. Being in Florida, with all of the bad drivers, my brights are pretty much on all of the time. And wouldn't you know it, by the end of the day, the high beam on the right headlight is burned out!

Since the low beam still worked, I kind of figured that it was one of the filaments that went bad. I brought it into the shop today, they took the lens off, and voila! It wasn't just the bulb.

Apparently, the plastic socket thing that the bulb plugs into melted in such a way that the high beam lead melted into the socket! Upon opening the light, the tech said, "ooooh, that's not good," and asked me if I ran different bulbs (which I don't).

Luckily, I have about 23 months left on my warranty, so this is going to be a warranty issue where they will replace the harness. So, until then, I'm driving all Ducati-style with one headlight. My question is this...

Is this a known-problem? The service guy said he's never seen this problem before, and unfortunately Triumph was closed for the day, so I'll have to wait for a diagnosis for tomorrow. Any insight would be greatly appreciated!
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Four problem StevieH Triumph SuperSports 5 04-16-2007 01:03 PM
Speed 3 going in for brake problem Raynewb RAT - United Kingdom 6 02-17-2007 01:02 PM
96 speed triple carb problem ? bueller T3 Sport / Touring Forum 4 12-12-2006 02:52 AM
Speed Four: Problem List WildRice Triumph SuperSports 16 07-07-2004 04:47 PM
First problem with my Speed Four! Triumph SuperSports 2 04-16-2004 05:23 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome