Stalls at idle? - Page 3 - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Speed Triple Forum Rants and ravings about the best naked triple on the planet!

Reply
 
LinkBack Thread Tools Display Modes
Old 11-04-2012, 10:13 AM   #21 (permalink)
Member
Grand Prix 250
Main Motorcycle: '06 Speed Triple
 
Join Date: Jul 2008
Location: Chicago, IL
Posts: 63
Other Motorcycle: '80 Kawasaki KZ 750
Extra Motorcycle: '73 Yamaha TX650
I haven't checked since I got it back. I wouldve hoped they checked it :/

Yesterday I took the bike back out and it wasn't dropping as badly as the night before. This also only does this when I'm in gear , yank clutch and let off throttle. If its in neutral and I rev it, it settles right where it should.


Sent from my iPhone using Motorcycle.com Free App
killcity is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-20-2012, 08:36 AM   #22 (permalink)
Lifetime Premium
Site Supporter
Grand Prix 250
Main Motorcycle: 2005 Speed Triple
 
Join Date: Dec 2011
Location: DFW, TX
Posts: 56
Other Motorcycle: 2004 Speed Four
Extra Motorcycle: 2009 Kawasaki Versys
Ok, updating (finally) with a fix that worked for me.

I've got a buddy who is a former Triumph technician who helped me out. He had seen this exact same issue on a few different bikes, and in all cases it was related to the SAI system. Basically he told me that if one or more of the SAI hoses gets blocked up somehow, you get this problem. My solution was to do a SAI delete, just removed the system entirely, installed the block-off plates from British Customs, and uploaded a no-SAI map appropriate for my setup (the Arrow 3-1 since I'm running a Leo Vince 3-1 pipe).

The problem is completely solved, as is the weird hesitation I was feeling around 3k-4k rpm.

I hope that helps someone else. Check your SAI system to make sure it's actually flowing air when it should, or just do a SAI delete and upload an appropriate map.
__________________
2005 Speed Triple
2004 Speed Four
2009 Versys
1997 DR350SE
Jehos is offline   Reply With Quote Quick reply to this message
Old 05-15-2013, 11:06 PM   #23 (permalink)
Member
Grand Prix 250
Main Motorcycle: '06 Speed Triple
 
Join Date: Jul 2008
Location: Chicago, IL
Posts: 63
Other Motorcycle: '80 Kawasaki KZ 750
Extra Motorcycle: '73 Yamaha TX650
Jehos - just ordered the block off plates. Bike has been running pretty well in the mean time. It only starts the low idle thing after its been run for about an hour and it seems to last for about 5-10 mins then goes away. I've already removed the o2 sensor, plugged and deleted with tune ecu. Now to block off the SAI....

More stuff I can remove the less crap to breakdown on me and cause these problems!


Sent from Motorcycle.com App
killcity is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalls off idle GearHd6 ECM and FI Tuning - Help, Tips & Tricks 3 06-13-2011 03:34 AM
Unstable idle and stalls Greyboy Daytona Deliberations 15 08-16-2010 08:57 PM
New Bonnie stalls at idle...HELP!!! monks_point Twins Technical Talk 8 08-08-2009 10:25 PM
stalls, won't idle tgreco50 Classic, Vintage & Veteran 7 07-06-2008 05:48 PM
Trophy stalls out at idle. dogg Trophy 11 11-09-2005 04:44 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 07:37 PM.



Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0