Upgrade Regulator Rectifier Install - Page 7 - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Maintenance Tips and Tricks for your Sprint Maintenance tips, tricks, performance suggestions and proven setups for the Sprints DO NOT POST YOUR QUESTIONS HERE!! Please post questions to the general forum.

Reply
 
LinkBack Thread Tools Display Modes
Old 01-09-2012, 04:13 PM   #61 (permalink)
New Member
Newbie
 
Join Date: Jan 2008
Posts: 2
I did this conversion about a year ago and it had worked very well. Recently I have been off of the bike for about 6 months due to a hip injury. Now the charging is again very weak with a maximum of 13.7 volts, and an idle voltage of only 12 volts.

This has been the worst part of my 2003 Sprint ST. Over the years I have changed 3 stators and 3 R/R units. I had hoped that this would be the end of it.

Any ideas of where to start before I tear it all apart again?
luscherrat is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-09-2012, 05:33 PM   #62 (permalink)
Lifetime Premium
Site Supporter
Supernova
Main Motorcycle: 2011 Sprint GT 1050
 
DaveM's Avatar
 
Join Date: Mar 2005
Location: Brisbane Australia
Posts: 22,331
Other Motorcycle: 2004 Daytona 955
Extra Motorcycle: Previously - Many
Quote:
Originally Posted by luscherrat View Post
I did this conversion about a year ago and it had worked very well. Recently I have been off of the bike for about 6 months due to a hip injury. Now the charging is again very weak with a maximum of 13.7 volts, and an idle voltage of only 12 volts.

This has been the worst part of my 2003 Sprint ST. Over the years I have changed 3 stators and 3 R/R units. I had hoped that this would be the end of it.

Any ideas of where to start before I tear it all apart again?
If you have gone through 3 stators and 3 R/R's are you replacing the R/R's with the same type or what?

DaveM
__________________


My album click here;

http://www.triumphrat.net/memberalbu...er/2712/sort/3
DaveM is online now   Reply With Quote Quick reply to this message
Old 01-09-2012, 07:00 PM   #63 (permalink)
Senior Member
Powerbike
Main Motorcycle: T160 Trident,H2 750,03955
 
Join Date: Nov 2011
Location: covington co.alabama
Posts: 310
Other Motorcycle: Buell S3T
Extra Motorcycle: nev er seen one
reply

It's alway's nice to see factory shortcomming's shunted!
Ironshoe is offline   Reply With Quote Quick reply to this message
Old 01-10-2012, 10:19 PM   #64 (permalink)
Senior Member
Powerbike
Main Motorcycle: T160 Trident,H2 750,03955
 
Join Date: Nov 2011
Location: covington co.alabama
Posts: 310
Other Motorcycle: Buell S3T
Extra Motorcycle: nev er seen one
3 stator's&3R/R unit's,HUH..That's definitly 5 too many of something,tell us how many AC volt's are you getting at R/R input,should be at least 19volt's AC coming from stator.. however I'm concerned about stator rotor itself,that's usual cause of multible stator failure's&high on my list of suspect's,suggest checking for wobble of stator rotor first,then report back.Also let me know if the acrid odour of cooked wiring has been present recently,there may be other culprit's lurking about too check 30amp main fuse for 13.75VDC or better voltage&get me a beer while your up too..No really in all seriousness many thing's could be going on but don't fear,we'll get through it together,just report back with answer's for my?'s& together we'll see it through to completion and this problemo will haunt you no more..Shoe...OUT!

Last edited by Ironshoe; 01-10-2012 at 10:40 PM.
Ironshoe is offline   Reply With Quote Quick reply to this message
Old 09-11-2012, 02:28 PM   #65 (permalink)
Premium Member
Site Supporter
Supersport 600
Main Motorcycle: Sprint 1050
 
tomservo's Avatar
 
Join Date: Aug 2012
Location: Nashville, TN
Posts: 155
Getting ready to do this mod on my 06 Sprint as well after reading through this thread. I'm actually not having problems getting good charge right now but sounds like it's a cheap way to gain a lot of piece of mind. I'm going with the triumph replacement wiring kit to make this as plug & play as possible.
tomservo is offline   Reply With Quote Quick reply to this message
Old 09-13-2012, 02:30 PM   #66 (permalink)
Member
Grand Prix 250
Main Motorcycle: 07 Triumph Sprint ST
 
steelincable's Avatar
 
Join Date: Jun 2012
Location: Bloomington IL
Posts: 41
I just did this on my ST last night. I went with the Triumph cable from BikeBandit. I found the safety latch on the female ends which plugged in the stock bike connectors to be way too loose. In fact the stator connection could almost disconnect internally without the safety latch coming apart. So, I ran a zip tie around the male/female connected assembly for both the stator and battery connection.

I didn't snap a picture, but after you make the connections, just pull them apart to test the safety latch and you'll see what i mean. There's way too much movement to leave it like that.

I did some before/after voltage measurements and they came out about the same. The new Mosfet unit stayed between 14.0 and 14.4 with the brights and heated grips on at any RPM. The old unit never went under 14, but went a hair over 15 at 5krpm.

Last edited by steelincable; 09-13-2012 at 02:33 PM.
steelincable is offline   Reply With Quote Quick reply to this message
Old 12-08-2012, 10:33 AM   #67 (permalink)
Member
Grand Prix 125
 
Join Date: Jan 2010
Posts: 33
I noticed on the pic where you taped off 1 plug and showed the stator plug open and ready for the upgrade. My question is, was the taped off plug the brown and black connector that goes foward with another harness from the OEM R/R? The stock set up on my ST has a connector attached to positive side/30 amp fuse with black/brown wires that goes forward to another harness. Please advise....really don't want to see alot of smoke.
Thanks, redonly
redonly is offline   Reply With Quote Quick reply to this message
Old 12-20-2012, 01:20 PM   #68 (permalink)
Lifetime Premium
Site Supporter
Commentator
Main Motorcycle: 06 ST, BOTM, 09-10 BOTY
 
oldndumb's Avatar
 
Join Date: Mar 2006
Location: Florida
Posts: 9,047
Other Motorcycle: 05SV1K, 2012 Ducati M1100
Quote:
Originally Posted by redonly View Post
I noticed on the pic where you taped off 1 plug and showed the stator plug open and ready for the upgrade. My question is, ....
I thought this thread was for info only, and that questions were to be posted to the general forum.
__________________
Oldndumb
Caveat lector
oldndumb is offline   Reply With Quote Quick reply to this message
Old 12-21-2012, 03:34 PM   #69 (permalink)
Lifetime Premium
Site Supporter
Supernova
Main Motorcycle: 2011 Sprint GT 1050
 
DaveM's Avatar
 
Join Date: Mar 2005
Location: Brisbane Australia
Posts: 22,331
Other Motorcycle: 2004 Daytona 955
Extra Motorcycle: Previously - Many
Correct OND as usual


Sent from my iPhone using Motorcycle.com App
__________________


My album click here;

http://www.triumphrat.net/memberalbu...er/2712/sort/3
DaveM is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging System Diagnostics - Rectifier/Regulator Upgrade DEcosse Speed Triple Forum 13 12-09-2013 03:45 PM
Regulator / Rectifier help Erickex Daytona Deliberations 12 06-16-2009 09:44 PM
Regulator/Rectifier GoinPostal Maintenance & Workshop Talk 3 07-31-2008 01:45 AM
Where to buy rectifier/regulator the955iman Maintenance & Workshop Talk 4 08-16-2007 04:28 AM
Rectifier/Regulator bratpane Triumph SuperSports 3 08-18-2006 05:43 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:30 PM.



Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0