Throttle Issues on 2003 Speedmaster. Help? - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Cruisers - America, Speedmaster Cruiser chat for America and Speedmasters

Reply
 
LinkBack Thread Tools Display Modes
Old 11-30-2012, 10:06 PM   #1 (permalink)
New Member
Minitwins
Main Motorcycle: 2003 Triumph Speedmaster
 
Join Date: Oct 2012
Location: Clemson, SC, USA
Posts: 11
Throttle Issues on 2003 Speedmaster. Help?

So I've been getting some great rides in (1000 miles per month) which have included interstate travelings with speeds upward of 70mph. Last week I went on a ride with a group and she was performing great. Problems started when speed limit went from 45mph (which I had been at for 20+ minutes) to 60 mph. She lurched backwards, felt differently and sounded differently all at the same time. She wouldnt go above 4000 rpms even with the throttle pulled completely down. I pulled over at the nearest gas station. Completely cut everything off and started her back up. After some hard revs she started acting normal again. Same thing with similar scenarios append twice on the ride home.

I'm no genius with engines but I figure it had to be something with bad gas or bad spark plugs. But the plugs are less than a month old. Any help on diagnosing or solutions?


Sent from my iPhone using Motorcycle.com Free App
drhutton92 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-01-2012, 09:38 AM   #2 (permalink)
Senior Member
Formula Extreme
Main Motorcycle: 2009 Blue & White America
 
MattyMo's Avatar
 
Join Date: Jan 2010
Location: northwest Florida, USA
Posts: 858
Quote:
Originally Posted by drhutton92 View Post
I'm no genius with engines but I figure it had to be something with bad gas or bad spark plugs. But the plugs are less than a month old. Any help on diagnosing or solutions?
From what you said it could be fuel related. There are a couple of things you can check before taking carbs apart. There is a screen for the petcock in the tank and there is a "hidden" fuel filter it the T pipe at the end of the fuel hose. The "hidden" filter can cause issues if it clogs. How many miles are on the odometer?
There are ignition things that can almost seem like fuel flow issues so do some searches here for your symptoms. Little things like opening the fuel cap to make sure it's not a vacuum or tank vent problem can show up. Good luck with it.
__________________
2009 America with some mods, a lot of fun that I can ride all day. (sold and miss my 2008 Bonneville, a great daily driver)
this message was created using recycled electrons
MattyMo is offline   Reply With Quote Quick reply to this message
Old 12-02-2012, 01:16 AM   #3 (permalink)
Senior Member
Formula Extreme
Main Motorcycle: '03 America
 
Join Date: Oct 2008
Location: San Francisco
Posts: 705
Other Motorcycle: GS750 rat
Extra Motorcycle: GS750 chop
MattyMo's advice will get you off to a good start. Here's another person's pic of that filter you need to check.



There is also the screen on the petcock inside the tank, but I'd exhaust the other checks before bothering with that.

The crack-the-gas-cap trick will tell you if it's a clogged breather tube, but you might as well get under there and check/modify the breather tubes for the tank and carbs:
http://www.triumphrat.net/cruisers-a...ml#post2387328

If it is on the electrical side of things, start with the easy stuff like clean and dielectric grease the connectors(everything, but particularly the spark plug wires and the wires feeding the coils), coil check(resistance checks), spark check.
http://www.triumphrat.net/cruisers-a...tting-out.html

Not quite in line with your symptoms, more of a problem at lower speeds when they go bad, but check the vacuum caps/lines while going over everything. 4 nipples to check total, 1 carb side and 1 manifold side for each carb. Still have the air injector system on it?
Verde is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 speedmaster 790 dgerber05 Twins Talk 1 08-15-2012 09:37 PM
2003 thunderbird tach issues and running rough konstrukt Hinckley Classic Triples 5 07-06-2010 09:55 PM
Throttle issues KitNYC Sprint Forum 2 02-07-2010 07:47 PM
Throttle Issues Train Sprint Forum 38 11-30-2009 04:20 AM
2003 955i Throttle stick NEV1050 Daytona Deliberations 0 12-12-2008 01:34 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 02:57 PM.



Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0