Broke down. - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
Air Cooled Twins Technical Talk Technical Talk for Hinckley Triumph Twins: Bonneville, T100, Speedmaster, America, Thruxton, and Scrambler.


Sponsored by: Triumph Twin Power Ltd

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 19 (permalink) Old 10-23-2012, 11:31 PM
Senior Member
SuperSport
Main Motorcycle: Triumph Street Triple
 
Johnnystriple's Avatar
 
Join Date: May 2012
Location: Owensboro, Ky.
Posts: 1,267
Other Motorcycle: 2012 Bonneville Standard
Extra Motorcycle: 2008 Harley Street Glide
Quote:
Originally Posted by mrbassett View Post
I ended up dropping it of at the shop, I was able to bribe him to stay late with a 12 pack of beer.

When I got there the bike had cooled off a bit and it started right up. He said: "do you want to ride it home now?"

Lol.

We kept it running for about 7 minutes and then it cut out again. At least I wasn't crazy.

We can pretty much rule out something with the fuel system and look at electrical issues.

I will let you all know what we find.

Thanks again for the suggestions.


Sent from my iPhone using Motorcycle
Well a promise is a promise.
Johnnystriple is offline  
Sponsored Links
Advertisement
 
post #12 of 19 (permalink) Old 10-29-2012, 07:19 PM
Member
Grand Prix 250
Main Motorcycle: BMW1150RT
 
Join Date: May 2010
Location: San Francisco Bay area
Posts: 54
Other Motorcycle: Bonneville
Same problem with my 2007. A dealer recomended I remove the Air Injection system. I did and the problem is history.
jeffhorn is offline  
post #13 of 19 (permalink) Old 10-29-2012, 11:24 PM Thread Starter
Member
Supersport 400
Main Motorcycle: 2015 Street Triple
 
Join Date: Jun 2012
Location: santa monica
Posts: 81
Sorry for the radio silence. I got a not from my mech and he said it was the pick up coil.

I am kinda bummed since I would have loved to do the work myself, but when I broke down I was much closer to the shop than my house.
mrbassett is offline  
post #14 of 19 (permalink) Old 10-30-2012, 11:19 PM
AMC
Member
Grand Prix 250
Main Motorcycle: 2006 Bonneville T100
 
Join Date: Sep 2012
Location: New Orleans
Posts: 57
Glad to hear you're back on the road. Was it an expensive repair?
AMC is offline  
post #15 of 19 (permalink) Old 10-30-2012, 11:23 PM Thread Starter
Member
Supersport 400
Main Motorcycle: 2015 Street Triple
 
Join Date: Jun 2012
Location: santa monica
Posts: 81
Welllllll, I'm still waiting on the part.


It's gonna be about $200 + $75 for the part.
mrbassett is offline  
post #16 of 19 (permalink) Old 11-20-2012, 08:33 PM Thread Starter
Member
Supersport 400
Main Motorcycle: 2015 Street Triple
 
Join Date: Jun 2012
Location: santa monica
Posts: 81
Update:

I replaced the pick up coil, but that didn't remedy the problem.

Luckily my mechanic was working on another Bonnie at the time and was able to systematically swap parts until he found which was failing. It turned out to be the ignitor.

Based on recommendations here on the forum, I went with the procom. It is getting installed today and hopefully I'll be able to go on a ride on Thanksgiving!
mrbassett is offline  
post #17 of 19 (permalink) Old 11-21-2012, 12:33 AM
Member
Grand Prix 125
Main Motorcycle: 2003 Bonneville
 
Join Date: Dec 2008
Location: Balham, London, UK
Posts: 37
Other Motorcycle: 2003 Bonneville 790cc
Extra Motorcycle: Vespa 90
Just a suggestion:
Check the petrol filter, this could have become clogged. I've had recurring similar symptoms for a while. I remove the petrol tap and usually find sediment round the base.
thurleigh5 is offline  
post #18 of 19 (permalink) Old 11-21-2012, 12:54 AM Thread Starter
Member
Supersport 400
Main Motorcycle: 2015 Street Triple
 
Join Date: Jun 2012
Location: santa monica
Posts: 81
Quote:
Originally Posted by thurleigh5 View Post
Just a suggestion:
Check the petrol filter, this could have become clogged. I've had recurring similar symptoms for a while. I remove the petrol tap and usually find sediment round the base.
Thanks. I will check that too.


Sent from my iPhone using Motorcycle.com App
mrbassett is offline  
post #19 of 19 (permalink) Old 11-22-2012, 12:17 AM Thread Starter
Member
Supersport 400
Main Motorcycle: 2015 Street Triple
 
Join Date: Jun 2012
Location: santa monica
Posts: 81
Got her back today. Replaced the pick up coil and the ignitor with a procom.

She is up and running, had a nice ride home in pre-thanksgiving traffic

I am a happy man.
mrbassett is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broke down already help roxiedog13 Cruisers - America, Speedmaster 3 07-06-2011 09:49 PM
HELP - broke off bar end markstaylor72 Speed Triple Forum 3 02-02-2009 09:41 PM
If it ain't broke, don't fix it. mglemans86 Biker Hang-Out 5 03-20-2008 10:12 PM
If it ain't broke...--? DaleE Hinckley Classic Triples 13 12-15-2007 09:24 PM
Anyone broke one of these? (pic) RCR001 Sprint Forum 11 07-27-2006 05:29 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome